最新ros双线叠加+负载分流

warning: 这篇文章距离上次修改已过567天,其中的内容可能已经有所变动。


ADSL
动态IP自动找到
:local assign-address
:local new-address
:local status
:local x
:set x 2
:for i from=1 to=$x do={
    :set status [/interface get [/interface find  name=("pppoe-out" . $i)] running]
    :if ($status=true) do={
     :set new-address [/ip address get [/ip address find dynamic=yes interface=("pppoe-out" . $i)] address]
     :set new-address [:pick $new-address 0 ([:len $new-address] -3)]
     :set assign-address [/ip address get [/ip address find dynamic=no interface=("pppoe-out" . $i)] address]
     :set assign-address [:pick $assign-address 0 ([:len $assign-address] -3)]
        :if ($assign-address != $new-address) do={ /ip address set [/ip address find comment=$i] address=$new-address network=$new-address broadcast=$new-address
        /ip route set [/ip route find comment=$i] gateway=$new-address
        /ip fir nat set [/ip fir nat find comment=$i] to-addresses=$new-address
        /ip route set [/ip route find comment=$i] gateway=$new-address
       }
   }
}

 


双线+LAN+IP
/ip address add address=192.168.0.1/255.255.255.0 interface=lan comment=lan
/ip dns set primary-dns=202.96.134.133 secondary-dns=202.96.128.68 allow-remote-requests=yes
/ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1440
/interface pppoe-client add name="pppoe-out1" interface=wan1 user="123" password="123" add-default-route=no disabled=no
/interface pppoe-client enable pppoe-out1
/ip address add address=58.58.58.1/32 interface=pppoe-out1 comment="1"
/ip route add gateway=58.58.58.1 routing-mark=1 comment="1"
/ip firewall mangle add chain=prerouting in-interface=lan connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=1 passthrough=yes disabled=no
/ip firewall mangle add chain=prerouting in-interface=lan connection-mark=1 action=mark-routing new-routing-mark=1 passthrough=no disabled=no
/ip firewall nat add chain=srcnat connection-mark=1 action=src-nat to-addresses=58.58.58.1 to-ports=0-65535 comment="1" disabled=no
/interface pppoe-client add name="pppoe-out2" interface=wan2 user="456" password="456" add-default-route=no disabled=no
/interface pppoe-client enable pppoe-out2
/ip address add address=58.58.58.2/32 interface=pppoe-out2 comment="2"
/ip route add gateway=58.58.58.2 routing-mark=2 comment="2"
/ip firewall mangle add chain=prerouting in-interface=lan connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=2 passthrough=yes disabled=no
/ip firewall mangle add chain=prerouting in-interface=lan connection-mark=2 action=mark-routing new-routing-mark=2 passthrough=no disabled=no
/ip firewall nat add chain=srcnat connection-mark=2 action=src-nat to-addresses=58.58.58.2 to-ports=0-65535 comment="2" disabled=no

#命令行加adsl
/ interface pppoe-client add name="pppoe-out1" interface=wan1 user="ADSL账号" password="ADSL密码" add-default-route=no disabled=no

 / interface pppoe-client enable pppoe-out1

  / interface pppoe-client add name="pppoe-out2" interface=wan2 user="ADSL账号" password="ADSL密码" add-default-route=no disabled=no

  / interface pppoe-client enable pppoe-out2


#做标记
 / ip firewall mangle

  add chain=prerouting in-interface=Local connection-state=new nth=1,1,0

  action=mark-connection new-connection-mark=1 passthrough=yes

  add chain=prerouting in-interface=Local connection-mark=1 action=mark-routing

  new-routing-mark=1 passthrough=no

  / ip firewall mangle

  add chain=prerouting in-interface=Local connection-state=new nth=1,1,1

  action=mark-connection new-connection-mark=2 passthrough=yes

  add chain=prerouting in-interface=Local connection-mark=2 action=mark-routing

  new-routing-mark=2 passthrough=no

 

none
最后修改于:2023年05月08日 08:38

评论已关闭